OpenWrt化済みバッファロー無線LANルーターWZR-HP-AG300Hのブリッジ運用法の改善

OpenWrt化済みバッファロー無線LANルーターWZR-HP-AG300Hブリッジとして運用し始めたものの、どうもすっきりしないところがあった。

OpenWrt Wikiの

Buffalo WZR-HP-AG300H [OpenWrt Wiki]” の “Network Port Assignments” の項に掲載されている内部構成図

基本以下のようにしていた。

  • eth0、eth1とWNICをブリッジ、
  • ポート0–4をVLAN #1として定義

ポート0は内部ポートでeth0とつながっているため、結局これら全部にまたがってブリッジが形成され、思うような挙動をしてくれたのだと思う。だが、ブリッジの設定でeth0ではなくVLAN #1であるeth0.1を直接指定することもできたので、そちらの方がeth0とするよりいいのか悪いのか疑問に思った。

多少は自分でも勉強し、以下の資料にもあった結果、それで問題ないのだろうと結論づけた。ただ、その方がパフォーマンス的に有利であるとか、不利であるとか、無関係である、とかいうことについてはわからない。

その結論に基づくLuCIによる設定画面が以下の通り:

‘lan”のブリッジに’eth0’ではなくVLANの’eth0.1’を加える

VLAN機能はオフにしてもデフォルトのVLAN #1はあるということがわかったので、VLANについては安心して以下のようにした(ただし、VLANはうかつにオフにしてはならないということを後で思い知ることになる)。

TagするならCPUのポートでは?

TagするならCPUのポートでは?

CPUのポート0についてはtaggedにする必要はないと思うんだが、つけても問題なかろうか、と。つけないほうがパフォーマンス的にはよいのかな?

とにもかくにも、以上の設定で得られた/etc/config/networkの内容は以下の通り。

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

config globals 'globals'
 option ula_prefix 'fd3c:bbab:4f3b::/48'

config interface 'lan'
 option force_link '1'
 option type 'bridge'
 option proto 'static'
 option netmask '255.255.255.0'
 option ip6assign '60'
 option gateway '192.168.11.1'
 option broadcast '192.168.11.255'
 option dns '192.168.11.2'
 option _orig_ifname 'eth0 wlan0 wlan1'
 option _orig_bridge 'true'
 option ipaddr '192.168.11.11'
 option ifname 'eth0.1 eth1'

config switch
 option name 'switch0'
 option reset '1'
 option mirror_source_port '0'
 option mirror_monitor_port '0'

config switch_vlan
 option device 'switch0'
 option vlan '1'
 option vid '1'
 option ports '0t 1 2 3 4'

 

広告

OpenWrt化済みバッファロー無線LANルーターWZR-HP-AG300Hのブリッジ運用法の改善」への2件のフィードバック

  1. ピンバック: ポータブル無線LANルータNexx WT3020Fを使えなくしてしまった | あくまで暫定措置としてのブログ
  2. ピンバック: OpenWrt搭載デバイスに外部USBメモリで記憶容量を増やす | あくまで暫定措置としてのブログ

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中